GitLab for Visual Studio 확장 프로그램 문제 해결
GitLab v19.3요약
이 페이지의 단계로 문제가 해결되지 않으면 확장 프로그램 프로젝트의 미해결 이슈 목록을 확인하세요. Visual Studio에서 GitLab Duo Chat 또는 GitLab Duo Code Suggestions를 사용할 수 없는 경우:
이 페이지의 단계로 문제가 해결되지 않으면 확장 프로그램 프로젝트의 미해결 이슈 목록을 확인하세요. 문제와 일치하는 이슈가 있으면 해당 이슈를 업데이트하세요. 일치하는 이슈가 없으면 새 이슈를 생성하세요.
GitLab Duo 기능이 표시되지 않는 경우#
Visual Studio에서 GitLab Duo Chat 또는 GitLab Duo Code Suggestions를 사용할 수 없는 경우:
-
사전 요구사항을 충족하는지, 필요한 설정이 활성화되어 있는지 확인하세요.
-
관리자 모드가 비활성화되어 있는지 확인하세요.
-
GitLab Duo Agentic Chat이 활성화되어 있는지 확인하세요.
Visual Studio에서 Tools > Options > GitLab으로 이동하세요.
-
GitLab 아래에서 General을 선택하세요.
-
Enable Agentic Duo Chat이 True로 설정되어 있는지 확인하세요.
-
-
Code Suggestions가 활성화되어 있는지 확인하세요.
Visual Studio 하단 상태 표시줄에서 GitLab 아이콘의 툴팁을 통해 현재 기능 상태를 확인하세요.
- Code Suggestions가 활성화되어 있지 않으면, 상단 바에서 Extensions > GitLab > Toggle Code Suggestions를 선택하세요.
Code Suggestions 지원에 대해서는 Code Suggestions 문제 해결을 참조하세요.
네트워크 문제#
로그에서 GitLab Duo의 /-/cable WebSocket 엔드포인트 대신 HTTP/1.1 응답이 표시된다면,
WebSocket 연결이 차단된 것일 수 있습니다.
GitLab 인스턴스는 IDE 클라이언트의 인바운드 WebSocket 연결을 허용해야 합니다. 이 문제가 의심된다면 네트워크 관리자에게 GitLab 인스턴스로의 WebSocket 트래픽 허용을 요청하세요.
GitLab Duo Agent Platform 연결이 WebSocket 오류 1006 또는 404로 실패하면
WebSocket 오류 1006 또는 404로 연결 실패를 참조하세요.
더 많은 로그 확인#
더 많은 로그는 GitLab Extension Output 창에서 확인할 수 있습니다.
-
Visual Studio 상단 바에서 Tools > Options 메뉴로 이동하세요.
-
GitLab 옵션을 찾아 Log Level을 Debug로 설정하세요.
-
View > Output으로 이동하여 확장 프로그램 로그를 여세요. 드롭다운 목록에서 로그 필터로 GitLab Extension을 선택하세요.
-
디버그 로그에 다음과 유사한 출력이 포함되어 있는지 확인하세요.
GetProposalManagerAsync: Code suggestions enabled. ContentType (csharp) or file extension (cs) is supported.
GitlabProposalSourceProvider.GetProposalSourceAsync
활동 로그 확인#
확장 프로그램이 로드되지 않거나 충돌하는 경우, 활동 로그에서 오류를 확인하세요. 활동 로그는 다음 위치에 있습니다.
C:\Users\WINDOWS_USERNAME\AppData\Roaming\Microsoft\VisualStudio\VS_VERSION\ActivityLog.xml
디렉터리 경로의 다음 값을 교체하세요.
-
WINDOWS_USERNAME: 사용자의 Windows 사용자명. -
VS_VERSION: 설치된 Visual Studio의 버전.
지원 요청 시 필요한 정보#
지원팀에 문의하기 전에 최신 GitLab 확장 프로그램이 설치되어 있는지 확인하세요. Visual Studio는 최신 버전의 확장 프로그램으로 자동 업데이트됩니다.
영향을 받는 사용자로부터 다음 정보를 수집하여 버그 보고서에 제공하세요.
-
사용자에게 표시된 오류 메시지.
-
워크플로 및 Language Server 로그:
-
진단 출력:
Visual Studio를 열어 놓은 상태에서 상단 배너의 Help > About Microsoft Visual Studio를 선택하세요.
- 대화 상자에서 Copy Info를 선택하면 이 섹션에 필요한 모든 정보가 클립보드에 복사됩니다.
-
시스템 세부 정보:
Visual Studio를 열어 놓은 상태에서 상단 배너의 Help > About Microsoft Visual Studio를 선택하세요.
-
대화 상자에서 System Info를 선택하면 더 자세한 정보를 확인할 수 있습니다.
-
OS 유형 및 버전:
OS Name과Version을 복사하세요. -
머신 사양(CPU, RAM):
Processor와Installed Physical Memory (RAM)섹션을 복사하세요.
-
-
영향 범위를 설명하세요. 몇 명의 사용자가 영향을 받고 있나요?
-
오류 재현 방법을 설명하세요. 가능하면 화면 녹화를 포함하세요.
-
다른 GitLab Duo 기능이 어떻게 영향을 받는지 설명하세요.
Code Suggestions가 작동하고 있나요?
-
Web IDE의 GitLab Duo Chat이 응답을 반환하나요?
-
확장 프로그램 격리 테스트를 수행하세요. 다른 확장 프로그램이 문제를 유발하는지 확인하기 위해 다른 모든 확장 프로그램을 비활성화(또는 제거)해 보세요. 이를 통해 문제가 이 확장 프로그램에서 발생한 것인지, 외부 원인에서 발생한 것인지 파악할 수 있습니다.
-